WordPress AndyBlue Theme URL Cross-Site Scripting

There is new challenge for us who use WordPress as blogging tool. According Secunia, a new vulnerability in the AndyBlue theme for WordPress has been discovered. It can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed in the URL through the WordPress installation’s index.php script to searchform.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site. The vulnerability is confirmed in version 1.4. Other versions may also be affected. Solution is to edit the source code to ensure that input is properly sanitised.

Fortunately, my blog is not based on vulnerable theme, so I’m lucky again.

Read about this vulnerability here.

Share this... Tweet about this on TwitterShare on LinkedInShare on FacebookShare on Google+Email this to someone

Leave a Reply