WordPress Redoable Theme “s” Cross-Site Scripting

Recently, this blog experienced attacks or better to say XSS bug testing which, fortunately, was unsuccessful.

Yesterday John Martinelli has discovered a vulnerability in the Redoable theme for WordPress (I don’t use this theme – lucky again), which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed to the “s” parameter in the WordPress installation’s index.php script is not properly sanitised before it is returned to the user. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site.

The vulnerability is confirmed in version 1.2. Other versions may also be affected. Solution is to edit the source code to ensure that input is properly sanitised.

See Original Advisory here.

Share this... Tweet about this on TwitterShare on LinkedInShare on FacebookShare on Google+Email this to someone

Leave a Reply